Quantcast
Viewing latest article 9
Browse Latest Browse All 10

EIGRP Stub Routers again

When an EIGRP enabled router loses a neighbour, all routes through that neighbour need to be re-evaluated. Any feasible successors are immediately promoted to successors, and any other routes go active.

“go active” means that the EIGRP router asks all its neighbours if they have a route to the destination. Each router that is queried either responds in the affirmative, or it in turn asks its neighbours if any exist. Only after a router hears back from all its neighbours does it pass a “I don’t have this route” message back up the chain. This is the Diffusing Update Algorithm, or DUAL.

When DUAL takes too long to resolve a query, such as if the network gets busy, you get the stuck-in-active error, which means the query took more than 3 minutes to complete.

The solution (besides “get a smaller network”) to SIA is to limit the scope of your queries. There are two methods to do this. The first is summarization. When an EIGRP router summarizes a network out an interface, any queries for a summarized network coming in that interface are answered and not passed along. The second way is to declare routers as stub routers, which means that you don’t want them to act as a transit anyway.

I’ve written about EIGRP stub routers before, but after taking the BSCI exam I realized my knowledge on that topic wasn’t enough.


The lab today is a simple triangle. R1/R2 are part of the main network, there are redundant connections to the branch network R3. If the R1/R2 link should fail we don’t want traffic to transit the WAN (imagine there is a larger network hanging off of R1/R2). R3 is therefore a stub.

Image may be NSFW.
Clik here to view.
3 routers in a triangle formation

Corresponding dynagen code:


  
autostart = false 

[localhost]

[[7200]]
image = ..\images\c7200-p-mz.124-12.unzipped
npe = npe-400
ram = 192

[[ROUTER R1]]
f0/0 = R2 f0/0

[[ROUTER R2]]


[[ROUTER R3]]
s1/0 = R1 s1/0
s1/1 = R2 s1/1
f0/0 = LAN 1

Each network is a /24 and all routers have been set up with EIGRP. R3 has various routes on it that I'll use to test.


interface Loopback0
 ip address 9.9.9.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 3.3.3.3 255.255.255.0
 duplex half
router eigrp 1
 redistribute connected
 redistribute static
 network 3.3.3.3 0.0.0.0
 network 10.0.1.2 0.0.0.0
 network 10.0.2.2 0.0.0.0
 no auto-summary
!
ip route 2.2.2.0 255.255.255.0 9.9.9.2

The eigrp stub command turns a router into a stub. The router informs its peers that it is a stub, which cause them to scope the queries appropriately. There are several options to the stub command though:


R3(config-router)#eigrp stub ?
  connected      Do advertise connected routes
  leak-map       Allow dynamic prefixes based on the leak-map
  receive-only   Set IP-EIGRP as receive only neighbor
  redistributed  Do advertise redistributed routes
  static         Do advertise static routes
  summary        Do advertise summary routes
  

Before stubs, R2 sees:


R2#show ip route eigrp
     2.0.0.0/24 is subnetted, 1 subnets
D EX    2.2.2.0 [170/2297856] via 10.0.2.2, 00:09:33, Serial1/1
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2172416] via 10.0.2.2, 00:01:13, Serial1/1
     9.0.0.0/24 is subnetted, 1 subnets
D EX    9.9.9.0 [170/2297856] via 10.0.2.2, 00:09:36, Serial1/1
     10.0.0.0/24 is subnetted, 3 subnets
D       10.0.1.0 [90/2172416] via 10.0.0.1, 00:53:53, FastEthernet0/0

After configuring as a stub:


R2#show ip eigrp neighbors detail s1/1
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.0.2.2                Se1/1             14 00:00:41  127   762  0  45
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 3
   Stub Peer Advertising ( CONNECTED SUMMARY ) Routes
   Suppressing queries
R2#show ip route eigrp
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2172416] via 10.0.2.2, 00:01:03, Serial1/1
     9.0.0.0/24 is subnetted, 1 subnets
D EX    9.9.9.0 [170/2297856] via 10.0.2.2, 00:01:03, Serial1/1
     10.0.0.0/24 is subnetted, 3 subnets
D       10.0.1.0 [90/2172416] via 10.0.0.1, 00:01:05, FastEthernet0/0

So by default the peer advertises connected and summary routes. Indeed, the redistributed static route was dropped, but the redistributed connected route wasn't. The other, directly advertised, connected route to F0/0 was also distributed.

Trying "eigrp stub static", I see


R2#show ip eigrp neighbors detail s1/1
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.0.2.2                Se1/1             13 00:00:15  116   696  0  58
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 1
   Stub Peer Advertising ( STATIC ) Routes
   Suppressing queries
R2#show ip route eigrp
     2.0.0.0/24 is subnetted, 1 subnets
D EX    2.2.2.0 [170/2297856] via 10.0.2.2, 00:00:19, Serial1/1
     10.0.0.0/24 is subnetted, 3 subnets
D       10.0.1.0 [90/2172416] via 10.0.0.1, 00:04:43, FastEthernet0/0

This has removed the connected and redistributed connected routes, leaving only the redistributed static.

Curiously, trying "eigrp stub redistributed" ends up showing as "eigrp stub connected summary redistributed". The best I could do was "eigrp stub redistributed connected", I could not get redistributed by itself. The documentation seems to be quiet on the issue.

The final option is receive-only which causes the stub router to advertise no routes, but still receives routing updates:


R2#show ip eigrp neighbors detail s1/1
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.0.2.2                Se1/1             11 00:00:13   76   684  0  85
   Version 12.4/1.2, Retrans: 1, Retries: 0
   Receive-Only Peer Advertising ( No ) Routes
   Suppressing queries
R2#show ip route eigr
R2#show ip route eigrp
     10.0.0.0/24 is subnetted, 3 subnets
D       10.0.1.0 [90/2172416] via 10.0.0.1, 00:05:14, FastEthernet0/0
R3#show ip route eigrp
     10.0.0.0/24 is subnetted, 3 subnets
D       10.0.0.0 [90/2172416] via 10.0.2.1, 00:00:54, Serial1/1
                 [90/2172416] via 10.0.1.1, 00:00:54, Serial1/0

Also of note from the show ip eigrp neighbors detail command is the "Suppressing queries" line. This goes back to the original purpose of stub routers, namely to tell the neighbours not to send any DUAL queries, which means the router will not be a transit network, nor will it hold up the rest of the network from converging.

Content Copyright Sean Walberg

EIGRP Stub Routers again


Viewing latest article 9
Browse Latest Browse All 10

Trending Articles